Centos 6.10 (same on 6.9) - "You have not created a /boot/efi partition."

Issues related to hardware problems
Post Reply
kleseini
Posts: 1
Joined: 2022/01/04 10:29:29

Centos 6.10 (same on 6.9) - "You have not created a /boot/efi partition."

Post by kleseini » 2022/01/04 10:44:58

Hello,
(before you will ask why centos 6 - it's customer's request because of the support of outdated program which he would like to use - thank you)

I want to help with this issue, which is showing to me during the drive configuration. (more info in the picture) I've tried:

single EFI System Partitions on each drive

/boot/efi in RAID on each drive (has to be redundant, so I didn't try without RAID)

and as you can see in the picture, creating first /boot then /boot/efi

Each time it ends with the error "You have not created a /boot/efi partition.", which is not true at all.

Also, the installation triggers into EFI installation even that the LEGACY is configured in BIOS. Also, no EFI setting is done in the BIOS - MB is X11SSLF-F with BIOS Version 1.0b. Should that be a problem with the iso file which I'm using?

Please help me if you had this issue in history or have any idea; I will be very grateful for that.

User avatar
TrevorH
Site Admin
Posts: 31526
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 6.10 (same on 6.9) - "You have not created a /boot/efi partition."

Post by TrevorH » 2022/01/04 12:03:12

You should not be deploying new CentOS 6 installs at all. It's been out of support for more than 1 year now and already has several remotely exploitable vulnerabilities in various packages. If the customer MUST run 6 then get them to pony up for a RHEL EUS subscription and install RHEL 6.

CentOS does not support RAID for /boot/efi. To get it working at all you must configure it without and then add it post-install.

I'd also add that symptoms like the EFI vs Legacy boot option can often be caused by using "bad" tools to copy the iso image file to a USB stick - see the link in my sig below for the wiki page with more details.
CentOS 8 died a premature death at the end of 2021 - migrate to Rocky/Alma/OEL/Springdale ASAP.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are dead, do not use them.
Use the FAQ Luke

Post Reply

Return to “CentOS 6 - Hardware Support”