Page 1 of 1

Enable spellchecking in Kile

Posted: 2020/07/01 15:40:51
by CorentinBL
Hello everybody,

As a PhD student, I have to write my thesis using LaTeX. To do so, I use Kile 2.1.0 with KDE 4.3.4 on a computer with CentOS 6.9 (Linux kernel: 4.14.11-1.el6.elrepo.x86_64, GNOME 2.28.2).

I am looking for a way to spot spelling mistakes that make the proofreading time consuming. But in the Kile GUI, when I click Tools -> Spelling... or Tools -> Spelling (from cursor)..., nothing happens. In addition, "Spellcheck selection" is inactive so I can't click on it.

From what I understand, spellchecking is handled at the OS level and not by Kile specifically. However, I have checked in my package manager and aspell and hunspell, which are common spelling packages that I saw online when looking for a solution, are installed.

I have also found a French article that explains that a couple of lines should be added to the kdeglobals file (see step 2 here: ... -kile.html). I have tried it, but after rebooting the computer, nothing seems to have changed.

Finally, I have found that the language for spellchecking in KDE could be set using kcontrol, but it is not installed on my computer and, from what I understand, it is now deprecated.

If you have any ideas about how to solve this problem, I would be grateful to you for sharing it. If you need more information to help me, I will be happy to provide it.


(For your information, in case you might suggest to update CentOS 7 since 6.9 won't be updated after November 2020, I unfortunately can't. I have to use this OS version for other software that I use for my PhD. Thank you for your understanding.)

Re: Enable spellchecking in Kile

Posted: 2020/07/01 16:17:02
by TrevorH
You should at least update to CentOS 6.10 as that is the current version of CentOS 6 and contains security updates that you are currently missing. You will need to update to something newer after November as your system will become increasingly insecure over time. It's almost certain that whatever you run now will also run on newer versions as long as they do not require a kernel module in order to function. Perhaps you should try it!

From `yum provides '*/kcontrol'`:

Code: Select all

6:kdebase-4.3.4-10.el6.x86_64 : KDE Core Files
Repo        : base
Matched from:
Filename    : /usr/share/kde4/apps/kcontrol

Re: Enable spellchecking in Kile

Posted: 2020/07/07 09:29:30
by CorentinBL
Thank you Trevor for your recommendation about using CentOS 6.10. However, this won't be possible, as explained in a previous discussion (viewtopic.php?p=275710#p275710). I really wish I could update, but this is out of my control.

I have tried `yum provides '*/kcontrol'` and I am not sure what to do. From what I understand, 'yum provides' returns the packages that include kcontrol. However, I have tried installing some of them, including the package 6:kdebase-4.3.4-10.el6.x86_64 from your reply, but this does not seem to do anything. Are there any further steps to do ?