Page 1 of 1

Error Requires: (GLIBC_2.14) (64bit)

Posted: 2020/01/08 09:57:03
by lutfi.ardiansyah
Hello everyone, I want to install Rocketchat server on centos 6.8. when i installed

"yum install -y gcc-c ++ make mongodb-org nodejs"

Error: Package: mongodb-org-tools-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-mongos-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-server-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-shell-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: (GLIBC_2.14) (64bit)

Repo mongo

name=MongoDB Repository
baseurl= ... .0/x86_64/

Re: Error Requires: (GLIBC_2.14) (64bit)

Posted: 2020/01/08 18:52:21
by TrevorH
1) CentOS 6.8 is massively out of date (released 4 years ago!) and needs to be updated to 6.10 using yum update
2) CentOS 6 has less than one year of life left. Are you sure you want to set up new services on something that will need replacing soon?

3) The real source of your problem is that you are trying to install packages intended for CentOS 7 on CentOS 6 and that will not work. You need to uninstall and remove that CentOS 7 repo and install the CentOS 6 one. Or nuke CentOS 6 and install 7 or 8 and start over.