Error Requires: libc.so.6 (GLIBC_2.14) (64bit)

Issues related to applications and software problems
Post Reply
lutfi.ardiansyah
Posts: 1
Joined: 2020/01/08 09:47:36

Error Requires: libc.so.6 (GLIBC_2.14) (64bit)

Post by lutfi.ardiansyah » 2020/01/08 09:57:03

Hello everyone, I want to install Rocketchat server on centos 6.8. when i installed

"yum install -y gcc-c ++ make mongodb-org nodejs"

Error: Package: mongodb-org-tools-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: libc.so.6 (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-mongos-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: libc.so.6 (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-server-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: libc.so.6 (GLIBC_2.14) (64bit)
Error: Package: mongodb-org-shell-4.0.14-1.el7.x86_64 (mongodb-org-4.0)
           Requires: libc.so.6 (GLIBC_2.14) (64bit)

Repo mongo

[mongodb-org-4.0]
name=MongoDB Repository
baseurl=https://repo.mongodb.org/yum/redhat/7/m ... .0/x86_64/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-4.0.asc
Attachments
Untitled.png
Untitled.png (31.88 KiB) Viewed 123 times

User avatar
TrevorH
Forum Moderator
Posts: 27414
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error Requires: libc.so.6 (GLIBC_2.14) (64bit)

Post by TrevorH » 2020/01/08 18:52:21

1) CentOS 6.8 is massively out of date (released 4 years ago!) and needs to be updated to 6.10 using yum update
2) CentOS 6 has less than one year of life left. Are you sure you want to set up new services on something that will need replacing soon?

3) The real source of your problem is that you are trying to install packages intended for CentOS 7 on CentOS 6 and that will not work. You need to uninstall and remove that CentOS 7 repo and install the CentOS 6 one. Or nuke CentOS 6 and install 7 or 8 and start over.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 6 - Software Support”