Page 1 of 1

[Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/03 13:29:45
by SUP-AMIX
Hi,
--

What type of problem / behavior are you experiencing? What do you expect to find?

Losing the parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0), you must run the sysctl -p command.

Where are you experiencing this kind of behavior? In which environment?

Production environment

When does this behavior occur? How often? Several times? Sometimes?

The problem occurs several times a day!

What information can you provide about impacts and business impact?

Regarding the period, occurs daily and generates business impact!

Re: [Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/03 15:33:52
by TrevorH
On CentOS 6?

Is the interface going up and down a lot?

Re: [Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/03 19:46:08
by SUP-AMIX
On CentOS 6?
Yes! 6.10

Is the interface going up and down a lot?
No, the interface is working normally!

Re: [Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/03 21:31:53
by Errosion
How do you know it is losing that parameter?

I'm also guessing you have that parameter defined in /etc/sysctl.conf since you want to keep it persistent, yes?

Also, just poking around, it seems like that setting defaults to "0" already. When the issue occurs, what is that option getting set to?

Use

Code: Select all

sysctl -a | grep rp_filter
to see.

Re: [Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/03 23:01:57
by TrevorH
It would be normal for it to reset to the default if the interface is restarted. And that tends to happen quite often with VPNs...

Re: [Losing parameter setting (net.ipv4.conf.ipsec0.rp_filter = 0)]

Posted: 2019/12/04 12:45:10
by SUP-AMIX
Thank you. Your guess led me to the solution. :D

Baria / Mauricio