[SOLVED] Yum cannot see available updates

Issues related to applications and software problems
Post Reply
agrasso
Posts: 4
Joined: 2015/01/16 16:21:28

[SOLVED] Yum cannot see available updates

Post by agrasso » 2015/01/16 16:48:41

Hello all,

I'm having issues updating one of my CentOS 6 servers. I am using a Spacewalk server, but I don't think it is directly responsible here, since all of the other servers in the group updated fine.

The system that has problems:

Code: Select all

# uname -a
Linux myserver.mydomain.com 2.6.32-504.3.3.el6.x86_64 #1 SMP Wed Dec 17 01:55:02 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

# cat /etc/redhat-release
CentOS release 6.6 (Final)
My spacewalk server reports updates are available, but I can't see them on the client.

Code: Select all

# yum update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * epel: mirrors.mit.edu
 * extras: mirrors.maine.edu
 * updates: mirror.trouble-free.net
No Packages marked for Update
I have noticed that all of the packages that need to be updated show in extras.

Code: Select all

# yum list extras
...
perl.x86_64                              4:5.10.1-127.el6          @base                                   
perl-Algorithm-Diff.noarch               1.1902-9.el6              @base                                   
perl-Class-Singleton.noarch              1.4-6.el6                 @base                   
perl-Log-Dispatch.noarch                 2.27-1.el6                @epel                                   
perl-Log-Dispatch-FileRotate.noarch      1.19-4.el6                @epel 
...
For example, I know that perl-5.10.1-136.el6_6.1:4.x86_64 is available, but I can't see it.

Code: Select all

#yum list perl
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * epel: mirrors.mit.edu
 * extras: mirrors.maine.edu
 * updates: mirror.trouble-free.net
Installed Packages
perl.x86_64                                     4:5.10.1-127.el6                                      @base
All of my repositories appear to be enabled, and I've tried the various

Code: Select all

#yum clean all
#yum makecache
but still don't see the updates. My best guess at this point is that these package were left behind from a point-release upgrade of CentOS and are not available any more in the current 6.6 repo and therefore cannot be updated. Does this seem reasonable? Is there anything obvious that I'm missing? Is there anything I can do short of a re-install of CentOS to resolve this?

Any direction would be helpful.

Thanks
Last edited by agrasso on 2015/01/19 18:00:24, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 28020
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum cannot see available updates

Post by TrevorH » 2015/01/16 19:33:52

yum list extras doesn't do what you think it does:

Code: Select all

      yum list extras [glob_exp1] [...]
              List  the  packages installed on the system that are not available in any yum repository listed in
              the config file.
Are you sure your spacewalk server's repos aren't stuck at 6.5? CentOS 6.6 ships with perl-5.10.1-136.el6 and then there's an update to that to bring it to 5.10.1-136.el6_6.1
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

agrasso
Posts: 4
Joined: 2015/01/16 16:21:28

Re: Yum cannot see available updates

Post by agrasso » 2015/01/16 20:33:12

Hi TrevorH. Thanks for your reply.

That is what I understood yum list extras to do, but I see that I wasn't clear as to how I thought it was relevant. As you point out, 6.6 ships with perl-5.10.1-136.el6, but this install (which appears to be 6.6) has perl-5.10.1-127.el6 installed from base. perl-5.10.1-127.el6:4.x86_64 shipped with 6.5? maybe 6.4? I'm not really sure. But since that version is not in the 6.6 repo, it shows up in extras.

Am I correct in my understanding that when I upgraded to 6.6, all of the packages should have been also upgraded to their 6.6 counterpart? I think that the root of my problem, or at least a symptom of it, is that yum sees that these packages are no longer in any available repos and therefore cannot be updated?

I would very much like to be on the versions in the 6.6 repo. I included perl as a handy example, but i have a few dozen other packages in the same boat.

I am sure that my Spacewalk server is not stuck at 6.5. I patched 5 other CentOS 6 servers at the same time from Spacewalk, and they are all running the expected versions from 6.6.

Thanks,

User avatar
TrevorH
Forum Moderator
Posts: 28020
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum cannot see available updates

Post by TrevorH » 2015/01/16 22:22:45

I don't use spacewalk but as I understand it, it uses the RHN plugin to get repo information so I am not quite sure why your yum commands also list base and updates repos as well. That doesn't sound quite right. Are your repos using yum-plugin-priority? Do you have base/updates configured with a priority that might meant the spacewalk versions are being ignored as they are not prioritised?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

agrasso
Posts: 4
Joined: 2015/01/16 16:21:28

Re: Yum cannot see available updates

Post by agrasso » 2015/01/19 16:56:11

Thanks TrevorH,

I finally figured out what was going on here, but I'm a little ashamed to admit what it was. :oops:

In /etc/yum.conf another admin had added:

Code: Select all

exclude=mysql* perl* rrdtool*
This should have been the first place I looked, but hopefully this helps someone else in the future.

Thanks again for your input TrevorH.

larryas2
Posts: 6
Joined: 2013/01/01 17:21:05

Re: [SOLVED] Yum cannot see available updates

Post by larryas2 » 2019/12/16 18:49:19

Ha, this was exactly my issue on a similair problem. Thanks for the post!!

Post Reply

Return to “CentOS 6 - Software Support”