Where to find librsync

Issues related to applications and software problems
Post Reply
bravobih
Posts: 5
Joined: 2011/09/21 11:14:38

Where to find librsync

Post by bravobih » 2011/09/21 11:21:45

I'm trying to compile some program that requires librsync and I can't find such library in the repositories (for x86-64)
For Debian the manual says that I have to install librsync-dev, what is the analog for CentOS 64bit ?

Thank you.

beaker_
Posts: 43
Joined: 2011/07/06 15:28:39

Re: Where to find librsync

Post by beaker_ » 2011/09/21 11:38:27

[code]
yum list librsync*
Loaded plugins: fastestmirror, refresh-packagekit
Available Packages
librsync.i686 0.9.7-15.el6 epel-6
librsync.x86_64 0.9.7-15.el6 epel-6
librsync-devel.i686 0.9.7-15.el6 epel-6
librsync-devel.x86_64 0.9.7-15.el6 epel-6
[/code]

Add and grab what you need from epel repo.

r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Where to find librsync

Post by r_hartman » 2011/09/22 10:23:43

[quote]
bravobih wrote:
I'm trying to compile some program [/quote]

Have you made sure that the program you're trying to compile is not already available as an rpm through one of the many repositories available?
Compiling stuff on package-managed systems is not the best of ideas, please refer to the recommended reading.

EDIT: Oh, and welcome to the CentOS fora.

bravobih
Posts: 5
Joined: 2011/09/21 11:14:38

Re: Where to find librsync

Post by bravobih » 2011/09/25 04:59:11

Yes, of course I checked the RPM list - the program is not here.

bravobih
Posts: 5
Joined: 2011/09/21 11:14:38

Re: Where to find librsync

Post by bravobih » 2011/09/25 05:03:47

[quote]
beaker_ wrote:
[code]
yum list librsync*
Loaded plugins: fastestmirror, refresh-packagekit
Available Packages
librsync.i686 0.9.7-15.el6 epel-6
librsync.x86_64 0.9.7-15.el6 epel-6
librsync-devel.i686 0.9.7-15.el6 epel-6
librsync-devel.x86_64 0.9.7-15.el6 epel-6
[/code]

Add and grab what you need from epel repo.[/quote]

Yes, you are right, but the problem is that my system doesn't find the libraries:
[code]
yum list librsync*
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: ftp.otenet.gr
* centosplus: ftp.otenet.gr
* extras: ftp.otenet.gr
* updates: ftp.otenet.gr
base | 3.7 kB 00:00
centosplus | 3.5 kB 00:00
contrib | 951 B 00:00
extras | 951 B 00:00
updates | 3.5 kB 00:00
Error: No matching Packages to list
[/code]

User avatar
TrevorH
Forum Moderator
Posts: 29457
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Where to find librsync

Post by TrevorH » 2011/09/25 09:37:29

1) You haven't installed the RPM necessary to provide access to the EPEL repository
2) Your yum list command may not work because you didn't escape the * in librsync* (should be librsync\*)

If you do install the EPEL repository then you should also install one or other or both of yum-plugin-protectbase and yum-plugin-priorities

beaker_
Posts: 43
Joined: 2011/07/06 15:28:39

Re: Where to find librsync

Post by beaker_ » 2011/09/25 18:07:27

Assuming the OP hasn't already discovered it.

http://wiki.centos.org/AdditionalResources/Repositories?highlight=%28epel%29

Post Reply

Return to “CentOS 6 - Software Support”