Oracle database 11g prerequisite packages.

Issues related to applications and software problems
Post Reply
dydoria
Posts: 1
Joined: 2011/08/19 13:32:22

Oracle database 11g prerequisite packages.

Post by dydoria » 2011/08/19 14:15:42

Hi team,

I am trying to install Oracle database 11g in CentOS 6.0 but I am missing some prerequisite packages:
--
libaio-0.3.105
glibc-2.3.4-2.41
compat-libstdc++-33-3.2.3
libaio-devel-0.3.105
libgcc-3.4.6
libstdc++-3.4.6
unixODBC-2.2.11
unixODBC-devel-2.2.11
pdksh-5.2.14

Where do I find those?


Thanks,
Doria

User avatar
TrevorH
Forum Moderator
Posts: 28867
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Oracle database 11g prerequisite packages.

Post by TrevorH » 2011/08/19 16:54:21

Looks like you have a version of Oracle 11g designed to run on something like RHEL4. RHEL5 uses glibc-2.5, RHEL6 uses glibc-2.12 and you are looking for glibc-2.3.4 which must be ancient. Check the RPMs you have downloaded and make sure they are for the right release.

DjRakso
Posts: 3
Joined: 2011/08/23 12:34:41

Re: Oracle database 11g prerequisite packages.

Post by DjRakso » 2011/08/23 12:44:56

dydoria & TrevorH Oracle 11g database works for CentOS 6. From the bare minimal packages of CentOS 6 I also added bc + libaio + glibc packages.
Oracle listed that make, binutils should also be included for its requirements.

hoidat1boi
Posts: 15
Joined: 2011/09/12 07:11:49

Re: Oracle database 11g prerequisite packages.

Post by hoidat1boi » 2011/09/17 07:12:07

Hi Guys,

I'm a Linux newbie, and I'd like to install Oracle 11g, Release 2 Express Edition for Linux x86-64 on a new CentOS 6.0 x86-64 desktop that I just set up. I noticed in the Oracle documentation (http://download.oracle.com/docs/cd/E17781_01/install.112/e18802/toc.htm) that as far as the RHEL OS goes, this particular version of Oracle requires either RHEL 4.7 or RHEL 5.2. Does that mean that should use a computer running either CentOS 4.7 or Centos 5.2 in order to run this version of Oracle properly? If I can indeed run Oracle 11g, R2 XE on CentOS 6, what specific steps should I take to ensure that Oracle installs properly on my current CentOS 6.0 desktop setup?

Please Advise,

Silly Linux Newbie

Post Reply

Return to “CentOS 6 - Software Support”