problems with FTP

Issues related to applications and software problems
Post Reply
SkorPio
Posts: 5
Joined: 2011/07/22 20:44:19
Contact:

problems with FTP

Post by SkorPio » 2011/07/26 20:51:51

I am having some problems getting FTP to install (it does, sort of) and work correctly (using a non anonymous user, it doesnt).

I started off with a Basic Install of ver 6 and then did a YUM INSTALL vsFTPd, lftp, ftp, Telnet, so that i could catch all needed services.

I ran into problems almost immediately when trying to login into a wordpress installation on the linux box, it just wouldn't take any username with the supplied password, but allowed the basic ftp to use an anonymous connection. (yes i did play around with the vsftpd.conf, hosts.allow/hosts.deny files, vsftpd-virtual.conf)

I have searched in vain for a solution. I have uninstalled and reinstalled vsFTPd and ftp. I have set up users (via adduser) and virtual users (via PAM). I note that when i uninstall vsFTPd, there still is an FTP prompt that runs (it won't open a connection nor will it accept any user and password) but apparently is not hooking up to the right user configuration files.

Now i need to know how to *start from scratch* when it comes to FTP and vsFTPd. Since i used a scenario to create virtual users, how do i go about turning this off (deleting the conf file does not help, it still is linking to something) and deleting the users in the PAM database. This means deleting or returning to normal all of the things that i have tried and failed at.

Does FTP (via YUM Install ftp) work without anything else necessary (like vsFTPd)? If so then i need to start at FTP configuration before I do the vsFTPd install???? btw, what version is the basic FTP? i know that the vsFTPd is 2.2.2.

I have the same type question [url=https://www.centos.org/modules/newbb/viewtopic.php?topic_id=32324&forum=55]here[/url] (not answered) which is why i am asking it in a different way in a different forum.

I need to have either FTP or vsFTPd installed so that it can accept a username and userpassword for the wordpress plugins to work correctly.

I have been at this for 3 days now with little to no success. Can anyone help me here?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

problems with FTP

Post by gerald_clark » 2011/07/27 14:55:53

I don't have ftp installed on C6, but in C5 ftp is the client and vsftpd is the server.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: problems with FTP

Post by pschaff » 2011/07/30 17:51:25

As Gerald said - vsftpd is the server package and ftp provides the FTP client - same on CentOS-6 as on 5. The problem statement is very unclear, probably due to the confusion about client versus server, and I can't tell if you are having difficulty setting up the vsftpd service on your server or accessing a different system with an FTP client. Please read all the links in my signature and ask a smart question to get good help.

Starting a new topic on the same issue is bad form. This one is now locked. Discussions should proceed in the [url=https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=32324&forum=55]original thread[/url].

Post Reply

Return to “CentOS 6 - Software Support”