running konqueror as root; kwrite as root

Issues related to applications and software problems
Post Reply
Posts: 20
Joined: 2011/07/21 09:19:12
Location: FRANCE

running konqueror as root; kwrite as root

Post by ket_nn » 2011/07/22 21:25:30

I didn't find in my KDE installation any option in the menu to run file manager (konqueror, dolphin) as administrator (root).

When I run Konqueror from the Terminal as root I get the following message:
kdeinit4: Communication error with launcher. Exiting!

Dolphin gives a bit more:
(3528)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

(3527)/: KUniqueApplication: Pipe closed unexpectedly.

When I run Kwrite, it opens the corresponding window but gives error:
Could not start process Cannot talk to klauncher: Not connected to D-Bus server.

It appears that something is not well configured in my system.

Could someone bring some light on it, please ?

Thanks !

Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

running konqueror as root; kwrite as root

Post by pschaff » 2011/07/22 21:38:27

Don't do that. Running a GUI, or such GUI tools, as root is too dangerous. Everything should be run as a normal user and one should [url=]become root[/url] only as required.

Post Reply

Return to “CentOS 6 - Software Support”