libmodplug dependency issue

Issues related to applications and software problems
Post Reply
ket_nn
Posts: 20
Joined: 2011/07/21 09:19:12
Location: FRANCE

libmodplug dependency issue

Post by ket_nn » 2011/07/22 21:01:14

I am wondering how to work around the problem with the following vlc dependencies:


# yum update
Loaded plugins: fastestmirror, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: ftp.ciril.fr
* centosplus: ftp.ciril.fr
* elrepo: elrepo.imt-systems.com
* elrepo-extras: elrepo.imt-systems.com
* elrepo-kernel: elrepo.imt-systems.com
* extras: ftp.ciril.fr
* rpmforge: apt.sw.be
* rpmforge-extras: apt.sw.be
* updates: ftp.ciril.fr
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dmidecode.x86_64 1:2.11-0.1.el6.rfx set to be updated
---> Package dnsmasq.x86_64 0:2.57-1.el6.rfx set to be updated
---> Package glib-devel.x86_64 1:1.2.10-33.el6.rf set to be updated
---> Package gnote.x86_64 0:0.7.2-0.1.el6.rfx set to be updated
---> Package kernel.x86_64 0:2.6.32-71.29.1.el6.centos.plus set to be installed
---> Package kernel-firmware.noarch 0:2.6.32-71.29.1.el6.centos.plus set to be updated
--> Processing Dependency: libmodplug.so.0()(64bit) for package: vlc-1.1.9-1.el6.rf.x86_64
---> Package libmodplug.x86_64 0:0.8.8.3-1.el6.rf set to be updated
---> Package perl-DBD-MySQL.x86_64 0:4.014-1.el6.rfx set to be updated
---> Package perl-DBI.x86_64 0:1.616-1.el6.rfx set to be updated
--> Processing Dependency: perl(Test::Simple) for package: perl-DBI-1.616-1.el6.rfx.x86_64
---> Package python-paramiko.noarch 0:1.7.6-1.el6.rfx set to be updated
---> Package rdesktop.x86_64 0:1.7.0-0.1.el6.rfx set to be updated
---> Package rsync.x86_64 0:3.0.8-1.el6.rfx set to be updated
---> Package tcp_wrappers.x86_64 0:7.6-57.el6.rfx set to be updated
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el6.rfx set to be updated
--> Running transaction check
--> Processing Dependency: libmodplug.so.0()(64bit) for package: vlc-1.1.9-1.el6.rf.x86_64
---> Package perl-Test-Simple.noarch 0:0.98-1.el6.rfx set to be updated
--> Processing Dependency: perl(Test::Harness) >= 2.03 for package: perl-Test-Simple-0.98-1.el6.rfx.noarch
--> Running transaction check
--> Processing Dependency: libmodplug.so.0()(64bit) for package: vlc-1.1.9-1.el6.rf.x86_64
---> Package perl-Test-Harness.noarch 0:3.23-1.el6.rfx set to be updated
--> Finished Dependency Resolution
Error: Package: vlc-1.1.9-1.el6.rf.x86_64 (@rpmforge)
Requires: libmodplug.so.0()(64bit)
Removing: libmodplug-0.8.7-1.el6.rf.x86_64 (@rpmforge)
libmodplug.so.0()(64bit)
Updated By: libmodplug-0.8.8.3-1.el6.rf.x86_64 (rpmforge)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Thanks !

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

libmodplug dependency issue

Post by pschaff » 2011/07/22 21:11:36

Since the error is with an RPMforge package the best place to report it is on the Repoforge ML, and it appears a familiar name has already [url=http://lists.repoforge.org/pipermail/users/2011-July/022331.html]done it[/url]! :-)

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: libmodplug dependency issue

Post by AlanBartlett » 2011/07/23 00:38:07

Yes, we just need to wait for the relevant package to exit from the [i]Repoforge[/i] build system, be checked, signed and pushed to the repository. ;-)

In the meantime, you probably would like to update everything else, so just --

[code]
[b]sudo yum --disablerepo rpmforge\* update[/b]
[/code]

ket_nn
Posts: 20
Joined: 2011/07/21 09:19:12
Location: FRANCE

Re: libmodplug dependency issue

Post by ket_nn » 2011/07/23 08:50:15

it is ok for me.

thanks much !

Post Reply

Return to “CentOS 6 - Software Support”