Trying to compile package but libdrm-2.4.20 in repo is 4 versions to old.

Issues related to applications and software problems
Post Reply
rhess
Posts: 2
Joined: 2011/07/17 22:20:46

Trying to compile package but libdrm-2.4.20 in repo is 4 versions to old.

Post by rhess » 2011/07/18 04:17:56

I need to use a version of libdrm at least 2.4.24 but the repo only holds 2.4.20. I downloaded and installed version 2.4.26 but I can't get the configuration for my package to use the new version. Is there some where I can load a repo that would have the proper version, or how can I get the newer version in place of the old?

Thanks for your help.

r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Re: Trying to compile package but libdrm-2.4.20 in repo is 4 versions to old.

Post by r_hartman » 2011/07/18 11:12:46

Welcome to the CentOS fora. New users are encouraged to do the recommended reading as linked in my signature.

As to your question, you do not say what package you need to install, and why it would require newer versions of libraries.
Before you stroll any further down that path, I strongly recommend you read [url=http://wiki.centos.org/PackageManagement/SourceInstalls?highlight=%28installing%29|%28software%29]this wiki page[/url] on package management and source installs, as there are severe drawbacks on compiling from source on a package-based system.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Trying to compile package but libdrm-2.4.20 in repo is 4 ver

Post by pschaff » 2011/07/18 19:41:55

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

You will find libdrm-devel-2.4.25-1.el6.elrepo in the [url=http://elrepo.org/]ELRepo testing repo[/url]. It was built to support a later video driver, and if it gets out of testing will go to a new [elrepo-extras] repo as it replaces a core package. Feedback appreciated.

As far as compiling - building a package is the preferred approach. See [url=http://wiki.centos.org/HowTos/RebuildSRPM]how to rebuild SRPMs[/url] for some guidance.

rhess
Posts: 2
Joined: 2011/07/17 22:20:46

Re: Trying to compile package but libdrm-2.4.20 in repo is 4 versions to old.

Post by rhess » 2011/07/19 01:20:56

Sorry about the missing key to the question. I am wanting to install a solar system simulator called OpenUniverse and needs a 3D graphics package called Mesa. Mesa is an open-source implementation of the OpenGL specification - a system for rendering interactive 3D graphics. Trying to compile Mesa requires the lib libdrm at lease version 2.4.24. The version in the repo is 2.4.20.

Thanks to r_hartman for the direction on learning about package management. I'll read up on that.

Thanks to pschaff on the ELRepo path and SRPM. I'll attempt that once I understand better package management.

You've been a great help both, thanks and I'll keep you updated on my successes.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Trying to compile package but libdrm-2.4.20 in repo is 4 versions to old.

Post by pschaff » 2011/07/19 16:23:41

I suggest that before proceeding, review the recommended reading, particularly [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=28725&forum=54]Installing Software[/url], then as [url=http://wiki.centos.org/TipsAndTricks/BecomingRoot]root[/url] try[code]
yum list mesa\*[/code].

Then enable the EPEL repo and[code]yum install openuniverse[/code]

Best to ask the direct question up front: "How do I install Open Universe?"

Post Reply

Return to “CentOS 6 - Software Support”