Go Home Yum... You're Drunk : "xz compression not available"

Issues related to applications and software problems
Post Reply
Eleos
Posts: 1
Joined: 2014/05/21 19:10:04

Go Home Yum... You're Drunk : "xz compression not available"

Post by Eleos » 2014/05/21 19:16:38

Hello everybody, like the title says, yum tells me now : "xz compression not available" after I installed epel-release, and now... I can't more do anything with it.

Someone knows how can I solve this problem without uninstall EPEL ?


PS : xz is install... and works perfectly
Thanks.

User avatar
TrevorH
Forum Moderator
Posts: 31067
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by TrevorH » 2014/05/21 20:25:48

What does rpm -q epel-release say?
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by gerald_clark » 2014/05/21 20:34:35

And what does 'rpm -q xz' say?

User avatar
TrevorH
Forum Moderator
Posts: 31067
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by TrevorH » 2014/05/21 20:44:14

Recreated the problem here. You installed the wrong epel-release package. If you install the epel-release-7 package then it breaks yum with the xz compression not available error. You need to run yum remove epel-release which is enough to fix it then go back and get the correct epel-release package for el6 NOT the one for the as yet unreleased RHEL7/CentOS7.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

weetabixharry
Posts: 2
Joined: 2014/05/24 16:58:43

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by weetabixharry » 2014/05/24 17:17:35

I have exactly the same problem and am pretty certain I have installed the right epel-release package. In fact, I've tried installing all the versions I could find (5, 6 and 7) and they all give exactly the same error.

User avatar
TrevorH
Forum Moderator
Posts: 31067
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by TrevorH » 2014/05/24 17:50:39

Checked again and the problem occurs if you install the BETA EPEL 7 package. Even if you remove it and install the correct epel-release-6-8.noarch.rpm package, it leaves /var/cache/yum/$arch/6/epel there with an xz file cached there and then yum cannot read it. You need to first, yum remove epel-release then rm -rf /var/cache/yum/x86_64/6/epel (or the 32 bit version if your system is not 64 bit) then install the correct epel-release package.

The epel-release-7 package is for the, as yet, unreleased RHEL7/CentOS 7. If you install it on your el5 or el6 system then it will break yum.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

weetabixharry
Posts: 2
Joined: 2014/05/24 16:58:43

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by weetabixharry » 2014/05/24 18:05:39

Fantastic. Works perfectly. This had been annoying me all day - thank you very, very much!

sumolive
Posts: 1
Joined: 2014/10/20 17:46:25

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by sumolive » 2014/10/20 17:49:31

I am facing same and did whatever you wrote, but still same issue is coming..

root@localhost ~]# yum --enablerepo=remi,remi-php55 install php-pecl-apc php-cli php-pear php-pdo php-mysqlnd php-pgsql php-pecl-mongo php-sqlite php-pecl-memcache php-pecl-memcached php-gd php-mbstring php-mcrypt php-xml
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.amsiohosting.net
* extras: nl.mirror.eurid.eu
* ius: mirror.amsiohosting.net
* remi: remi.check-update.co.uk
* remi-php55: remi.check-update.co.uk
* updates: mirrors.viralvps.com
* webtatic: uk.repo.webtatic.com
Error: xz compression not available
[root@localhost ~]#


Please help me..i lost my 2 days into it.

danjohns7
Posts: 1
Joined: 2016/03/08 14:22:29

Re: Go Home Yum... You're Drunk : "xz compression not availa

Post by danjohns7 » 2016/03/08 14:24:52

Necro'ing an extremely dead thread, but in case anyone is still having this issue and epel's not at fault-

Check your Webtatic repo. You may have a mismatch there as well.

vi /etc/yum.repos.d/webtatic.repo

Change "enabled 1" to "enabled 0", "yum clean all", then "yum repolist."

SpencerThomas
Posts: 1
Joined: 2016/06/03 09:29:36

Re: Go Home Yum... You're Drunk : "xz compression not available"

Post by SpencerThomas » 2016/06/03 09:39:54

Thought I'd just add that TrevorH's solution worked for me.
I must have installed the wrong epel at first then spent a lot of time goggling trying to solve this 'phantom' problem.
Even if you remove it and install the correct epel-release-6-8.noarch.rpm package, it leaves /var/cache/yum/$arch/6/epel there with an xz file cached there and then yum cannot read it. You need to first, yum remove epel-release then rm -rf /var/cache/yum/x86_64/6/epel (or the 32 bit version if your system is not 64 bit) then install the correct epel-release package.
Everything's working now, thanks all!

Post Reply

Return to “CentOS 6 - Software Support”