6.4 x86_64 | can't get sendmail to start as service

Issues related to applications and software problems
Post Reply
cooch17
Posts: 68
Joined: 2009/01/09 22:13:05

6.4 x86_64 | can't get sendmail to start as service

Post by cooch17 » 2013/11/25 20:36:23

This should be simple -- yum installed sendmail and associated files, and for the life of me, I can get it to start as a service. The services gui reports the sendmail service as 'dead'.

SELinux off

port 25 opened


Any suggestions as to what to look at next? It been years since I had to tweak sendmail anythng (my other 5.xx boxes have been chugging along for 4-5 years -- which is how long ago I set things up).

Thanks in advance...

cooch17
Posts: 68
Joined: 2009/01/09 22:13:05

Re: 6.4 x86_64 | can't get sendmail to start as service

Post by cooch17 » 2013/11/25 20:38:56

Further, if I click the 'start' button in the GUI, it tells me the 'servic is being refreshed right now' (except that it never changes from this status).

I must be missing something obvious.

User avatar
TrevorH
Forum Moderator
Posts: 29159
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: 6.4 x86_64 | can't get sendmail to start as service

Post by TrevorH » 2013/11/26 01:09:21

The logs are in /var/log, sort them chronlogically with `ls -lart` and see which are being written to when you start it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

moonpup
Posts: 118
Joined: 2008/11/20 20:38:18

Re: 6.4 x86_64 | can't get sendmail to start as service

Post by moonpup » 2013/11/26 20:02:22

Try deleting the following file as root.

Code: Select all

rm /var/lock/subsys/sendmail
Then do a

Code: Select all

service sendmail start

cooch17
Posts: 68
Joined: 2009/01/09 22:13:05

Re: 6.4 x86_64 | can't get sendmail to start as service

Post by cooch17 » 2013/11/29 14:40:19

moonpup wrote:Try deleting the following file as root.

Code: Select all

rm /var/lock/subsys/sendmail
Then do a

Code: Select all

service sendmail start
That did the trick -- thanks!

Post Reply

Return to “CentOS 6 - Software Support”