Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

General support questions
Post Reply
vshankar
Posts: 2
Joined: 2020/10/13 11:26:20

Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

Post by vshankar » 2020/10/13 11:51:19

Hi,

I'm using CentOS 6.4 and ntpd(4.2.6P5-15.el6) is crashing and below is the call stack
gdb) bt
#0 input_handler (cts=0xfff3acf8) at ntp_io.c:3654
#1 0x00c9aaa6 in ntpdmain (argc=0, argv=0xd09344) at ntpd.c:1075
#2 0x00c9b28c in main (argc=3, argv=0xfff3ae04) at ntpd.c:354

The above crash is fixed as part of [NTP Bug 2224] Use-after-free in routing socket code after dropping root. - Commit: d6df9d3
The same fix is patched by centOS in ntp-4.2.6p5-29.el7 (https://git.centos.org/rpms/ntp/c/9e87e ... ?branch=c7)
but that is for centOS 7. When I try to install ntp-4.2.6p5-29.el7.centos.2.x86_64.rpm in my centos 6.4 it's failing because of (libc, libcrypto, libopts, ystemd-units) dependencies error.

So, can you please let me know the ntpd rpm with above crash fix for CentOS 6.4? Thanks is advance.

For more details on ntpd crash fix:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1481388
https://www.mail-archive.com/search?l=d ... newest&f=1

Thanks in advance
Vidya

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

Post by TrevorH » 2020/10/13 13:55:42

Sometimes I don't know where to start...

First 6.4 is *years* out of date and should not be used. And I mean literally _years_ it was released 2013-02-21.

The only supported CentOS 6 version is the latest, 6.10 and even then it's only supported for less than another 7 weeks. You need to be thinking about migrating to a newer version ASAP.

Run yum update to get to as close to up to date as you can get and remember that you only have less than 2 months to get off CentOS 6.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 3180
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

Post by jlehtone » 2020/10/14 10:10:20

CentOS 6.10 seems to have ntp-4.2.6p5-15.el6.centos. Same version that OP mentions?

CentOS 6.10 has also package chrony that is an alternative for ntp. (CentOS 7 and 8 have the chrony too.)
I could say that 'chrony' is the rpm that you are looking for. :old_ben:

vshankar
Posts: 2
Joined: 2020/10/13 11:26:20

Re: Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

Post by vshankar » 2020/10/21 08:16:37

Thanks TrevorH and jlehtone for the response.

TrevorH,

I already did yum update ntp in centOS 6.4 the latest version is ntp-4.2.6p5-15.el6.centos, but this does not have above ntpd crash fix.


jlehtone,

I don't want to use chrony, I need ntpd specifically.

I'm looking for ntpd rpm with above crash fix for CentOS 6.4? Please help here.

Thanks
Vidya

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Required ntpd rpm for centOS 6.4 with [NTP Bug 2224] fixed

Post by TrevorH » 2020/10/21 09:47:32

Since CentOS 6 dies in approximately 5 weeks time, you should be putting effort into getting off it ASAP not patching trivial flaws.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 6 - General Support”