Page 1 of 1

How to enable SOAP on CentOS

Posted: 2020/06/04 14:53:12
by Judith
We have VPS with CentOS I have installed soap with following command.

Code: Select all

yum install php-soap
Then I went to php.ini to un-comment soap extension. It was not there so, I added my own following line.

Code: Select all

extension=soap.so
Then i restart server with following command

service httpd restart
But SOAP is still not enabled. as i get Fatal error: Class 'SoapClient' If i try to install it again. I get following message PayGOnline.

Code: Select all

Package php-soap-5.3.3-27.el6_5.x86_64 already installed and latest version
I tried to re-configure PHP with following command as well.

Code: Select all

php-config '--disable-fileinfo' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pic' '--with-zlib' '--with-zlib-dir=/usr' '--enable-soap'
Any help?

Re: How to enable SOAP on CentOS

Posted: 2020/06/04 16:32:17
by TrevorH
I do not know the solution to your problem but I can tell you that the php-soap package already installs itself by supplying /etc/php.d/soap.ini which loads the extension so you did not need to add it to php.ini.

You should note that your system is out of date. The package php-soap-5.3.3-27.el6_5.x86_64 that you mention is now 5.3.3-50.el6_10 so you should `yum update` to get it. You should also know that CentOS 6 is on its last legs and will die in November this year. You should plan to migrate off it to a newer version sooner rather than later.

Running php-config is only of use if you rebuild everything and you don't want to do that. I am not sure that your Class 'SoapClient' error is caused by the lack of the extension in any case, that looks more like some php requirement is not installed, possibly a pear package or something like that.