Page 1 of 1

Teamviewer on CentOS 6

Posted: 2020/04/20 09:32:21
by ethio
i can't install anydesk or teamviewer i always get this error

Error: Package: teamviewer-15.4.4445-0.x86_64 (/teamviewer_15.4.4445.x86_64)
Requires: libc.so.6(GLIBC_2.17)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
thanks

Re: hello everyone

Posted: 2020/04/20 09:37:53
by TrevorH
You need to talk to the teamviewer people. The installer that you have there is built for CentOS 7 or later and will not run on CentOS 6. Perhaps they have a different one for the older version.

Please also read the sticky forum topic on the lifespan of CentOS 6 as it dies in approximately 6 months and you need to be planning to migrate to a newer version before then.

Re: Teamviewer on CentOS 6

Posted: 2020/04/20 09:40:26
by ethio
thanks for reply but i have centos 6.8 and 6.10 i have same problem to install anydesk if anydesk work i don't need teamviewer thanks

Re: Teamviewer on CentOS 6

Posted: 2020/04/20 10:09:00
by TrevorH
The answer is the same if the error is the same and there is nothing that we can do to fix it. The error you posted is saying that the glibc version on your system is too old to work with the application and you cannot update glibc so the app has to change.

The warning about CentOS 6 dying in November is even more true for 6.8 which is already 4 *years* out of date and riddled with security vulnerabilities.