yum update won't finish and cant install yum-utils to resolve

General support questions
Post Reply
mojoworkin
Posts: 1
Joined: 2020/02/22 22:19:26

yum update won't finish and cant install yum-utils to resolve

Post by mojoworkin » 2020/02/22 22:32:16

running CentOS release 6.10 (Final)

trying to run yum update, get the following error:

Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
* base: mirror.es.its.nyu.edu
* extras: mirror.ash.fastserv.com
* updates: ewr.edge.kernel.org
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package ksh.i686 0:20120801-37.el6_9 will be updated
---> Package ksh.x86_64 0:20120801-38.el6_10 will be an update
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.11)(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Processing Dependency: libutil.so.1()(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: ksh-20120801-38.el6_10.x86_64
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.212.el6_10.3 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3)(64bit) for package: glibc-2.12-1.212.el6_10.3.x86_64
--> Processing Dependency: libfreebl3.so()(64bit) for package: glibc-2.12-1.212.el6_10.3.x86_64
--> Running transaction check
---> Package nss-softokn-freebl.x86_64 0:3.44.0-6.el6_10 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

However, I cannot install yum-utils package to resolve as I get this error:
yum install yum-utils
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirror.es.its.nyu.edu
* extras: mirror.ash.fastserv.com
* updates: ewr.edge.kernel.org
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.

--> Running transaction check
---> Package yum-utils.noarch 0:1.1.30-42.el6_10 will be installed
--> Processing Dependency: libxml2-python for package: yum-utils-1.1.30-42.el6_10.noarch
--> Running transaction check
---> Package libxml2-python.x86_64 0:2.7.6-21.el6_8.1 will be installed
--> Processing Dependency: libxml2.so.2(LIBXML2_2.7.3)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.7.0)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.8)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.6)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.5)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.3)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.28)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.27)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.25)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.23)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.21)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.20)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.2)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.18)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.17)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.16)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.15)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.14)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.12)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.11)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.10)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.1)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.9)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.8)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.7)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.6)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.4)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.2)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.5.0)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.4)(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libz.so.1()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libxml2.so.2()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libutil.so.1()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: libxml2-python-2.7.6-21.el6_8.1.x86_64
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.212.el6_10.3 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3)(64bit) for package: glibc-2.12-1.212.el6_10.3.x86_64
--> Processing Dependency: libfreebl3.so()(64bit) for package: glibc-2.12-1.212.el6_10.3.x86_64
---> Package libxml2.x86_64 0:2.7.6-21.el6_8.1 will be installed
---> Package python-libs.x86_64 0:2.6.6-68.el6_10 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libexpat.so.1(EXPAT_2_0_1_RH)(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libtinfo.so.5()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libssl.so.10()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libsqlite3.so.0()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libreadline.so.6()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libpanelw.so.5()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libncursesw.so.5()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libgdbm.so.2()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libffi.so.5()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libexpat.so.1()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libcrypto.so.10()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
--> Processing Dependency: libbz2.so.1()(64bit) for package: python-libs-2.6.6-68.el6_10.x86_64
---> Package zlib.x86_64 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package bzip2-libs.x86_64 0:1.0.5-7.el6_0 will be installed
---> Package db4.x86_64 0:4.7.25-22.el6 will be installed
---> Package expat.x86_64 0:2.0.1-13.el6_8 will be installed
---> Package gdbm.x86_64 0:1.8.0-39.el6 will be installed
---> Package libffi.x86_64 0:3.0.5-3.2.el6 will be installed
---> Package ncurses-libs.x86_64 0:5.7-4.20090207.el6 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.44.0-6.el6_10 will be installed
---> Package openssl.x86_64 0:1.0.1e-58.el6_10 will be installed
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT)(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT)(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
--> Processing Dependency: libkrb5.so.3()(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
--> Processing Dependency: libk5crypto.so.3()(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
--> Processing Dependency: libgssapi_krb5.so.2()(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
--> Processing Dependency: libcom_err.so.2()(64bit) for package: openssl-1.0.1e-58.el6_10.x86_64
---> Package readline.x86_64 0:6.0-4.el6 will be installed
---> Package sqlite.x86_64 0:3.6.20-1.el6_7.2 will be installed
--> Running transaction check
---> Package krb5-libs.x86_64 0:1.10.3-65.el6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3)(64bit) for package: krb5-libs-1.10.3-65.el6.x86_64
--> Processing Dependency: libselinux.so.1()(64bit) for package: krb5-libs-1.10.3-65.el6.x86_64
--> Processing Dependency: libkeyutils.so.1()(64bit) for package: krb5-libs-1.10.3-65.el6.x86_64
---> Package libcom_err.x86_64 0:1.41.12-24.el6 will be installed
--> Running transaction check
---> Package keyutils-libs.x86_64 0:1.4-5.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-7.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================================================================
Package Arch Version Repository Size
==============================================================================================================================================================================================================================================
Installing:
yum-utils noarch 1.1.30-42.el6_10 updates 114 k
Installing for dependencies:
bzip2-libs x86_64 1.0.5-7.el6_0 base 36 k
db4 x86_64 4.7.25-22.el6 base 564 k
expat x86_64 2.0.1-13.el6_8 base 77 k
gdbm x86_64 1.8.0-39.el6 base 29 k
glibc x86_64 2.12-1.212.el6_10.3 updates 3.8 M
keyutils-libs x86_64 1.4-5.el6 base 20 k
krb5-libs x86_64 1.10.3-65.el6 base 675 k
libcom_err x86_64 1.41.12-24.el6 base 38 k
libffi x86_64 3.0.5-3.2.el6 base 26 k
libselinux x86_64 2.0.94-7.el6 base 109 k
libxml2 x86_64 2.7.6-21.el6_8.1 base 805 k
libxml2-python x86_64 2.7.6-21.el6_8.1 base 325 k
ncurses-libs x86_64 5.7-4.20090207.el6 base 245 k
nss-softokn-freebl x86_64 3.44.0-6.el6_10 updates 202 k
openssl x86_64 1.0.1e-58.el6_10 updates 1.5 M
python-libs x86_64 2.6.6-68.el6_10 updates 5.3 M
readline x86_64 6.0-4.el6 base 178 k
sqlite x86_64 3.6.20-1.el6_7.2 base 300 k
zlib x86_64 1.2.3-29.el6 base 73 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install 20 Package(s)

Total size: 14 M
Installed size: 49 M
Is this ok [y/N]: Exiting on user Command
Your transaction was saved, rerun it with:
yum load-transaction /tmp/yum_save_tx-2020-02-22-17-31o5vqJr.yumtx

please help resolve this

sml
Posts: 112
Joined: 2020/01/17 09:01:44

Re: yum update won't finish and cant install yum-utils to resolve

Post by sml » 2020/02/23 12:38:51

Sorry, but judging from
mojoworkin wrote:
2020/02/22 22:32:16
Is this ok [y/N]: Exiting on user Command
you didn't press y at the last prompt. May I ask why?

User avatar
TrevorH
Forum Moderator
Posts: 28026
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update won't finish and cant install yum-utils to resolve

Post by TrevorH » 2020/02/23 13:54:01

Could you also run and post the output from yum check. That will probably run for a long time - I've seen 45 minutes before now and depending on the machine and disk speed, could be quicker or slower.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 6 - General Support”