DELL T330 - Centos 6.10 no boot

General support questions
Post Reply
ZetaKappa
Posts: 3
Joined: 2020/01/22 15:51:40

DELL T330 - Centos 6.10 no boot

Post by ZetaKappa » 2020/01/22 15:55:08

hi there, just a newbee in CentOS and Linux world, just to be honest.
Trying to install CentOS 6.10 in brand new DELL T330 Server

2 SSD disk 500Gb in Raid 1
Bios set to RAID (other option is AHCI)
Boot mode set to UEFI (other option is Bios)

Setup from internal CD, is ok, than after succesfully installing no sign of life.

Tried to change any option in bios, switched to AHCI / BIOS mode but nothing happening.

Any hint?

User avatar
TrevorH
Forum Moderator
Posts: 28069
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: DELL T330 - Centos 6.10 no boot

Post by TrevorH » 2020/01/22 16:34:26

I'd recommend NOT installing CentOS 6 on a new install. It has less than 1 year of life left before all updates for it will stop. It's not a long term solution to anything. Use CentOS 7 or even 8 instead.

Based on your description of "Bios set to RAID (other option is AHCI)" I would guess that this is not a hardware RAID controller but what is known as FakeRAID. If the model of RAID controller starts with an S, for example an S100, then it is not a real hardware RAID controller, it's FakeRAID. In which case the recommendation is that you blow away the existing array (backup anything you need first!) then set the controller to AHCI mode and install using Linux Software RAID instead.

You may also need to remove the FakeRAID metadata from the disks before they can be seen by CentOS. Boot the install DVD in rescue mode and use something like dmraid -E -r /dev/sdX where /dev/sdX is one of the drives you want to wipe. That command is from memory and may well be wrong so check the man page before you use it in case my memory is faulty.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

ZetaKappa
Posts: 3
Joined: 2020/01/22 15:51:40

Re: DELL T330 - Centos 6.10 no boot

Post by ZetaKappa » 2020/01/22 17:32:07

Thanks, i think i got a HW Raid Controller, not a fake one. But tomorrow i’ll check.

I know Centos 6 is going to be unsupported soon, but i need exactly that version for business purpose :(

User avatar
TrevorH
Forum Moderator
Posts: 28069
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: DELL T330 - Centos 6.10 no boot

Post by TrevorH » 2020/01/22 19:17:05

In 6 months time you will be trying to work out how to migrate to a newer version...
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

ZetaKappa
Posts: 3
Joined: 2020/01/22 15:51:40

Re: DELL T330 - Centos 6.10 no boot

Post by ZetaKappa » 2020/01/22 21:58:08

TrevorH wrote:
2020/01/22 19:17:05
In 6 months time you will be trying to work out how to migrate to a newer version...
I will surely report this to my Project Manager.
Based on your esperience, with AHCI mode on, uefi boot should i be able to install CentOS on a Raid 1 Array?
I think i should have a 330controller not a fake One (s140?)

Whoever
Posts: 1104
Joined: 2013/09/06 03:12:10

Re: DELL T330 - Centos 6.10 no boot

Post by Whoever » 2020/01/23 03:51:07

ZetaKappa wrote:
2020/01/22 17:32:07

I know Centos 6 is going to be unsupported soon, but i need exactly that version for business purpose :(
That's what virtualization is for.

Post Reply

Return to “CentOS 6 - General Support”