Page 1 of 1

How to install Apache, Mariadb, PHP and phpMyAdmin on CentOS 6.10?

Posted: 2018/12/06 18:11:29
by tanquang
What partition should I create for my server with 4GB of RAM, 2TB HDD to install programming language / tools / product / server program as follows:
-> Apache: v2.4.37
-> PHP: v5.6.39
-> Mariadb: v10.3 (or v10.4)
-> phpMyAdmin: v4.8.3
And how do I install them on CentOS 6.10?
Thank you! :D

Re: How to install Apache, Mariadb, PHP and phpMyAdmin on CentOS 6.10?

Posted: 2018/12/06 18:17:37
by TrevorH
If you're doing a fresh install now then you probably don't want to use CentOS 6. It's 8 years old and has only 2 years left before it dies. In addition, none of the package versions you mention are included in CentOS 6 which has apache httpd 2.2.15, php 5.3.3, mysql 5.1 (and we don't ship phpmyadmin at all).

CentOS 7 is "only" 4 years old and still has 6 years of life left. It has apache httpd 2.4.6 (plus various backports by Redhat), php 5.4.16, mariadb 5.5 and still no phpmyadmin.

Re: How to install Apache, Mariadb, PHP and phpMyAdmin on CentOS 6.10?

Posted: 2018/12/07 16:30:21
by Whoever
phpmyadmin is available in EPEL.