yum update error

General support questions
punktuga21
Posts: 30
Joined: 2017/08/04 08:40:51

yum update error

Post by punktuga21 » 2017/08/04 08:46:00

Error: Package: openwsman-server-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: openwsman-client-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: libwsman-devel-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: MariaDB-shared-10.1.19-1.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.17)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Can somebody help me please?

User avatar
TrevorH
Forum Moderator
Posts: 28571
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update error

Post by TrevorH » 2017/08/04 08:56:36

It looks like a problem with packages supplied by Centreon and you should ask them about the problems.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

punktuga21
Posts: 30
Joined: 2017/08/04 08:40:51

Re: yum update error

Post by punktuga21 » 2017/08/04 09:06:23

oh sorry. thank you for the help :)

User avatar
TrevorH
Forum Moderator
Posts: 28571
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update error

Post by TrevorH » 2017/08/04 09:11:24

Wait, I just spotted you have a mix of .el6. and /el7/ packages listed tehre so I suspect you've installed the wrong yum repo for Centreon. You need the one to match your CentOS version which appears to be 6 and you have installed the repo for 7. Remove it, add the correct one, run yum clean all then try again.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

punktuga21
Posts: 30
Joined: 2017/08/04 08:40:51

Re: yum update error

Post by punktuga21 » 2017/08/04 14:10:06

TrevorH wrote:Wait, I just spotted you have a mix of .el6. and /el7/ packages listed tehre so I suspect you've installed the wrong yum repo for Centreon. You need the one to match your CentOS version which appears to be 6 and you have installed the repo for 7. Remove it, add the correct one, run yum clean all then try again.
I removed both repo but still gives me error
Error: Package: centreon-clib-1.4.2-3.el7.centos.x86_64 (centreon-stable)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: centreon-connector-ssh-1.1.2-3.el7.centos.x86_64 (centreon-stable)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: centreon-connector-ssh-1.1.2-3.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: centreon-clib-1.4.2-3.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.15)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 28571
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update error

Post by TrevorH » 2017/08/04 15:26:31

So you switched out the el7 repo for the el6 one. Did you then run yum clean all ?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

punktuga21
Posts: 30
Joined: 2017/08/04 08:40:51

Re: yum update error

Post by punktuga21 » 2017/08/04 15:32:04

TrevorH wrote:So you switched out the el7 repo for the el6 one. Did you then run yum clean all ?
Yeah mate and this continues

User avatar
TrevorH
Forum Moderator
Posts: 28571
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update error

Post by TrevorH » 2017/08/04 15:40:27

Show the full output from yum update from where you enter the command right up to when the command prompt returns.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

punktuga21
Posts: 30
Joined: 2017/08/04 08:40:51

Re: yum update error

Post by punktuga21 » 2017/08/04 15:48:34

TrevorH wrote:Show the full output from yum update from where you enter the command right up to when the command prompt returns.
[root@localhost ~]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
* base: mirrors.up.pt
* extras: mirrors.up.pt
* updates: mirrors.up.pt
* webtatic: uk.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-compat.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: MariaDB-common for package: MariaDB-compat-10.1.19-1.el7.centos.x86_64
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package libtasn1.x86_64 0:2.3-6.el6_5 will be updated
--> Processing Dependency: libtasn1 = 2.3-6.el6_5 for package: libtasn1-devel-2.3-6.el6_5.x86_64
---> Package libtasn1.x86_64 0:2.4-1.el5.art will be an update
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman1 = 2.2.3-11.el6 for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman1 = 2.2.3-11.el6 for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman1 = 2.2.3-11.el6 for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package mysql-libs.x86_64 0:5.1.73-8.el6_8 will be obsoleted
--> Running transaction check
---> Package MariaDB-common.x86_64 0:10.1.19-1.el7.centos will be installed
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package libtasn1.i686 0:2.3-6.el6_5 will be installed
---> Package libtasn1.x86_64 0:2.3-6.el6_5 will be updated
---> Package libwsman1.i686 0:2.2.3-11.el6 will be installed
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: libwsman1-2.2.3-11.el6.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30) for package: libwsman1-2.2.3-11.el6.i686
--> Processing Dependency: libxml2.so.2 for package: libwsman1-2.2.3-11.el6.i686
--> Processing Dependency: libcurl.so.4 for package: libwsman1-2.2.3-11.el6.i686
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package libcurl.i686 0:7.19.7-53.el6_9 will be installed
--> Processing Dependency: libssh2(x86-32) >= 1.4.2 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libz.so.1 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssl3.so(NSS_3.4) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssl3.so(NSS_3.2) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssl3.so(NSS_3.14) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssl3.so(NSS_3.11.4) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssl3.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libssh2.so.1 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libsmime3.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libplds4.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libplc4.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnssutil3.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.9.3) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.9.2) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.5) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.4) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.3) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.2) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.12.5) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.12.1) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.12) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so(NSS_3.10) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnss3.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libnspr4.so for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libldap-2.4.so.2 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libkrb5.so.3 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libk5crypto.so.3 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libidn.so.11(LIBIDN_1.0) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libidn.so.11 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT) for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: libcurl-7.19.7-53.el6_9.i686
--> Processing Dependency: libcom_err.so.2 for package: libcurl-7.19.7-53.el6_9.i686
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package libxml2.i686 0:2.7.6-21.el6_8.1 will be installed
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package krb5-libs.i686 0:1.10.3-65.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-65.el6.i686
---> Package libcom_err.i686 0:1.41.12-23.el6 will be installed
---> Package libidn.i686 0:1.18-2.el6 will be installed
---> Package libssh2.i686 0:1.4.2-2.el6_7.1 will be installed
--> Processing Dependency: libssl.so.10 for package: libssh2-1.4.2-2.el6_7.1.i686
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10) for package: libssh2-1.4.2-2.el6_7.1.i686
--> Processing Dependency: libcrypto.so.10 for package: libssh2-1.4.2-2.el6_7.1.i686
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package nspr.i686 0:4.13.1-1.el6 will be installed
---> Package nss.i686 0:3.28.4-3.el6_9 will be installed
--> Processing Dependency: nss-softokn(x86-32) >= 3.14.3-22 for package: nss-3.28.4-3.el6_9.i686
--> Processing Dependency: libsoftokn3.so for package: nss-3.28.4-3.el6_9.i686
--> Processing Dependency: libnssdbm3.so for package: nss-3.28.4-3.el6_9.i686
---> Package nss-util.i686 0:3.28.4-1.el6_9 will be installed
---> Package openldap.i686 0:2.4.40-16.el6 will be installed
--> Processing Dependency: libsasl2.so.2 for package: openldap-2.4.40-16.el6.i686
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package cyrus-sasl-lib.i686 0:2.1.23-15.el6_6.2 will be installed
--> Processing Dependency: libdb-4.7.so for package: cyrus-sasl-lib-2.1.23-15.el6_6.2.i686
---> Package keyutils-libs.i686 0:1.4-5.el6 will be installed
---> Package libselinux.i686 0:2.0.94-7.el6 will be installed
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package nss-softokn.i686 0:3.14.3-23.3.el6_8 will be installed
--> Processing Dependency: libsqlite3.so.0 for package: nss-softokn-3.14.3-23.3.el6_8.i686
---> Package openssl.i686 0:1.0.1e-57.el6 will be installed
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package db4.i686 0:4.7.25-22.el6 will be installed
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package sqlite.i686 0:3.6.20-1.el6_7.2 will be installed
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.6.20-1.el6_7.2.i686
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package readline.i686 0:6.0-4.el6 will be installed
--> Processing Dependency: libtinfo.so.5 for package: readline-6.0-4.el6.i686
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.1.19-1.el7.centos will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: MariaDB-shared-10.1.19-1.el7.centos.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.2.3-11.el6 will be updated
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-server-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libwsman-devel-2.2.3-11.el6.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: openwsman-client-2.2.3-11.el6.x86_64
---> Package libwsman1.x86_64 0:2.6.2-1.el7.centos will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwsman1-2.6.2-1.el7.centos.x86_64
---> Package ncurses-libs.i686 0:5.7-4.20090207.el6 will be installed
--> Finished Dependency Resolution
Error: Package: openwsman-server-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: openwsman-client-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: libwsman-devel-2.2.3-11.el6.x86_64 (@base)
Requires: libwsman_client.so.1()(64bit)
Removing: libwsman1-2.2.3-11.el6.x86_64 (@base)
libwsman_client.so.1()(64bit)
Updated By: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Not found
Error: Package: libwsman1-2.6.2-1.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: MariaDB-shared-10.1.19-1.el7.centos.x86_64 (centreon-stable)
Requires: libc.so.6(GLIBC_2.17)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]#

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: yum update error

Post by gerald_clark » 2017/08/04 16:04:12

You have el5 el6 and el7 repos installed. That will never work.

Post Reply

Return to “CentOS 6 - General Support”