[RESOLVED]Cant start httpd service

General support questions
chamikara
Posts: 17
Joined: 2014/10/01 05:09:05

[RESOLVED]Cant start httpd service

Post by chamikara » 2015/10/06 06:06:53

Hi

Any Idea about this

service httpd start
Starting httpd: [Tue Oct 06 10:30:13 2015] [warn] module ssl_module is already loaded, skipping
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Tue Oct 06 10:30:13 2015] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
(98)Address already in use: make_sock: could not bind to address [::]:443
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Thanks
Chamikara
Last edited by chamikara on 2015/10/19 08:37:12, edited 1 time in total.

camservo
Posts: 1
Joined: 2015/10/06 08:06:27

Re: Cant start httpd service

Post by camservo » 2015/10/06 08:09:39

Services should be launched as root, and then the init script will run it as whichever user it's told to use.

Please try "sudo service httpd start".

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Cant start httpd service

Post by avij » 2015/10/06 08:16:04

You already have some process that is listening on the 443 port. Try netstat -anp | grep :443 to see which process that is. Once you know the process ID (rightmost column), you can get more information about the process (including its full path) with ps -fp processidnumber.

chamikara
Posts: 17
Joined: 2014/10/01 05:09:05

Re: Cant start httpd service

Post by chamikara » 2015/10/07 04:37:15

Hi

Thanks for reply . I checked the PID so what is the next step do i stop it.

Thanks

chamikara
Posts: 17
Joined: 2014/10/01 05:09:05

Re: Cant start httpd service

Post by chamikara » 2015/10/07 05:22:35

Hi
After I kill that process , i can start the httpd service but the thing is other application will stop. I need to up both services.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Cant start httpd service

Post by gerald_clark » 2015/10/07 05:54:29

You cannot have 2 services using the same port.

SeijiSensei
Posts: 12
Joined: 2015/10/05 21:25:41

Re: Cant start httpd service

Post by SeijiSensei » 2015/10/07 23:21:58

chamikara wrote:Hi
After I kill that process , i can start the httpd service but the thing is other application will stop. I need to up both services.
What other service?

pwd
Posts: 61
Joined: 2014/12/23 11:54:42

Re: Cant start httpd service

Post by pwd » 2015/10/08 05:47:51

gerald_clark use lsof to check what process is listening on the port

Code: Select all

# lsof -i :443
"God, root, what is difference?"

chamikara
Posts: 17
Joined: 2014/10/01 05:09:05

Re: Cant start httpd service

Post by chamikara » 2015/10/08 07:58:36

this is the out put i got
only 1 PID

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
java 4248 root 57u IPv6 1432326 0t0 TCP server01:53341->sb-in-f95.1e100.net:https (CLOSE_WAIT)
java 4248 root 138u IPv6 1166002 0t0 TCP *:https (LISTEN)
java 4248 root 203r IPv6 1432325 0t0 TCP server01:53340->sb-in-f95.1e100.net:https (CLOSE_WAIT)

pwd
Posts: 61
Joined: 2014/12/23 11:54:42

Re: Cant start httpd service

Post by pwd » 2015/10/08 08:46:01

So You got java application listeting on port 443 (https), if You need to run httpd on 443 you have to kill this application or change tcp port.
"God, root, what is difference?"

Post Reply

Return to “CentOS 6 - General Support”