Problem with sudo in 6.5 (final)

General support questions
Post Reply
11thhour
Posts: 3
Joined: 2013/12/05 20:19:28

Problem with sudo in 6.5 (final)

Post by 11thhour » 2013/12/07 22:29:21

After upgrading to 1.8.6p3-12.el6 I can no longer use the sudo command.

I receive the following error:

Code: Select all

sudo: PERM_ROOT: setresuid(0, -1, -1): too many processes
I am assuming there is a modification that I have to make to some configuration on how many processes can be run. But, I am not sure where this would be.

Any help would be appreciated.

Thanks.

scottro
Forum Moderator
Posts: 2533
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Problem with sudo in 6.5 (final)

Post by scottro » 2013/12/08 01:26:19

I wonder what would happen if you just uninstalled and reinstalled sudo. (And possibly rename /etc/sudoers to /etc/sudoers.old after uninstalling and before reinstalling) It might be some sort of minor difference in the default /etc/sudoers.

Note that this is a completely untested guess, but seems worth the minute or two it would take to try it.
New users should check the FAQ and Read Me First pages

11thhour
Posts: 3
Joined: 2013/12/05 20:19:28

Re: Problem with sudo in 6.5 (final)

Post by 11thhour » 2013/12/09 18:49:00

Thanks scottro,

I tried the suggestion. However, the issue still remains.

mastens
Posts: 1
Joined: 2013/12/13 23:53:59

Re: Problem with sudo in 6.5 (final)

Post by mastens » 2013/12/13 23:56:56

Hi guys!

I've got the exact same problem, after 6.5 upgrade. This is an openvz vps. But, don't think it should have something todo with it.
Tried to remove sudo package and install it again, with new config files and everything, still got the same problem.

Marius

11thhour
Posts: 3
Joined: 2013/12/05 20:19:28

Re: Problem with sudo in 6.5 (final)

Post by 11thhour » 2013/12/14 05:00:43

Marius,

Exactly same issue openvz vps as well. I should have mentioned that in the original post.

Troy.

DeX
Posts: 1
Joined: 2014/01/15 11:20:40

Re: Problem with sudo in 6.5 (final)

Post by DeX » 2014/01/15 11:24:14

Is there a fix for this issue in OpenVZ containers?

User avatar
TrevorH
Forum Moderator
Posts: 32031
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Problem with sudo in 6.5 (final)

Post by TrevorH » 2014/01/15 16:34:58

You'd have to ask the Openvz guys...
CentOS 8 died a premature death at the end of 2021 - migrate to Rocky/Alma/OEL/Springdale ASAP.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are dead, do not use them.
Use the FAQ Luke

hawkmage
Posts: 162
Joined: 2011/12/17 00:00:11

Re: Problem with sudo in 6.5 (final)

Post by hawkmage » 2014/01/16 04:00:19

I deal with many CentoOS servers that have been updated to 6.5 and we rely heavily on sudo for developers to access application UIDs and we have not see any issues.

Post Reply