Boot up freezes after certmonger starts.

General support questions
biondizzle
Posts: 1
Joined: 2012/10/29 19:38:24
Contact:

Boot up freezes after certmonger starts.

Post by biondizzle » 2012/10/29 19:56:00

Fresh net-install of Cent OS 6.3. Only thing I did different than the other installs that worked was installing Gnome. During boot-up right after it shows

Starting certmonger: [OK]

The screen flickers for a moment then it doesn't do anything, just sits there. Googled the issue, can't come up with anything. Not very linux fluent, I use cPanel for all of my server work if that explains my elementary knowledge. I've entered verbose mode by hitting a keyboard key when the animated splash boot screen/progress bar came up. Anyway to make it "more verbose" to find out what is failing?

Samsung QX411/Core i5/6gb ddr3/512 SanDisk SSD/Intel Display Laptop.

If any more information or details needed for someone to help me, just ask. Any help would be fantastic! Thank you so much for reading my question.
I've has CentOS 5 installed and Red Hat 9 on this Laptop before without an issue. Once again, my linux credibility is tiny, I hope I explained the issue well enough.
-Mike

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Boot up freezes after certmonger starts.

Post by gerald_clark » 2012/10/30 13:26:08

Contact you hoster or cPanel for support.
We cannot support machines that have cPanel installed.
They replace much of the system with their own versions.

kelpie
Posts: 1
Joined: 2013/02/18 05:16:39

Re: Boot up freezes after certmonger starts.

Post by kelpie » 2013/02/18 05:21:33

Just bumping this thread. I just had the same problem. Fresh installation on physical server of Centos 6.3 from DVD. All went well and then the first boot stalled at the certmonger check. I don't run cpanel. I also installed gnome packages.

Just wondering if anyone else has come across this and has an easy fix (otherwise I will try to post one when I get time to suss it out).

geoff_s
Posts: 1
Joined: 2013/02/21 07:42:20

Re: Boot up freezes after certmonger starts.

Post by geoff_s » 2013/02/21 08:01:07

I'm having the same issue, although not on a new install. It does stall just after "starting certmonger: [ok]" but I was able to SSH into the machine and get a command line. Using this as a hint (https://bugzilla.redhat.com/show_bug.cgi?id=891950) I restarted the messagebus service and then the certmonger service (which wasn't running initially). After that the normal boot process seemed to proceed ok, but the problem reoccurs when rebooting. Any suggestions how to resolve this ?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Boot up freezes after certmonger starts.

Post by gerald_clark » 2013/02/21 14:17:58

Starting certmonger: [OK]

That means certmonger is not the problem.
What service is started after certmonger? Look in the relevant rc.d directory or boot in interactive mode.
Stalls during startup are often due to a network problem and a service attempting a connection it can't make.

canuck15
Posts: 36
Joined: 2005/04/19 00:24:47

Boot up freezes after certmonger starts.

Post by canuck15 » 2013/03/06 19:19:34

I'm having exactly the same problem after installing gnome. Clean install from scratch. Anyone have a solution yet?

User avatar
TrevorH
Forum Moderator
Posts: 29918
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Boot up freezes after certmonger starts.

Post by TrevorH » 2013/03/06 20:47:03

Please don't hijack threads. Start your own and refer to this one in a link if you think it's similar.

At a guess, I'd say that you have a display driver problem and the system has just switched to GUI mode and is unable to display. Boot in runlevel 3 by interrupting the boot process at the grub prompt, edit the kernel command line and append a 3 to the end of it. Then login at the command prompt and run `startx` and see what happens. Examine /var/logXorg.0.log to see if it contains any explanatory error messages.

ngorichard
Posts: 1
Joined: 2013/03/11 15:28:53

Re: Boot up freezes after certmonger starts.

Post by ngorichard » 2013/03/11 15:32:24

To fix this,

ssh to your machine after it hangs.

mv /etc/X11/xorg.conf /etc/X11/old_xorg.conf

then reboot. That should fix it.

I found the issue after looking at the log file "/var/log/Xorg.0.log". Most probably, you are like me using virtual machine and after the update, the video card driver doesn't load anymore.

Hope this helps someone!

jettblack
Posts: 1
Joined: 2013/12/14 19:18:28

Re: Boot up freezes after certmonger starts.

Post by jettblack » 2013/12/14 19:20:55

I confirmed that after a kernel update, I had to ssh into my box and reinstall the Nvidia driver. Thanks for the help.

animesh303
Posts: 1
Joined: 2013/12/25 14:38:05

Re: Boot up freezes after certmonger starts.

Post by animesh303 » 2013/12/25 14:47:44

Thanks a lot. I have been spending the whole day guessing what went wrong. It appears if you have installed NVidia drivers from NVidia site manually and stopped using default driver Nouveau (like by blacklisting it during boot) which ships along with Distros like RHEL, each time you update the kernel you need to move to backup /etc/X11/xorg.conf file and re-install the driver to rebuild the kernel module. To enable login in nogui mode during these situations is to add parameter 3 at the boot configuration (press E twice after selecting the kernel at grub).

Post Reply

Return to “CentOS 6 - General Support”