Search found 9 matches

by lshekter
2006/03/31 02:32:33
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

OK. I rebuilt the rpm database (I think the switch is --rebuilddb not --initdb which according to the man pages creates the database initially, but perhaps I misread that). I tried everything again but still nothing works. I am now running CentOS 4.3 courtesy of apt, though I would prefer to fix up2...
by lshekter
2006/03/27 03:14:14
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

Yeah, I'd already tried rebuilding yum 2.4.2 from source, as many posts have suggested (even the yum FAQ). But believe it or not, that doesn't solve the problem! yum still doesn't work, only now the error is different: #yum There was a problem importing one of the Python modules required to run yum....
by lshekter
2006/03/26 23:12:51
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

# rpm -qa pyOpenSSL pyOpenSSL-0.6-1.p23 # rpm -qa rhpl rhpl-0.148.3-1 #rpm -qa 'up2date*' up2date-4.4.67-4.centos4 up2date-gnome-4.4.67-4.centos4 It seems like I have all the packages you mentioned, though not all at quite the same version level. yum *is* broken, to wit: #yum There was a problem imp...
by lshekter
2006/03/24 03:18:14
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

I updated the three packages as requested, but still no go :-( # rpm -Uvh rhn-applet-2.1.24-3.centos4.i386.rpm Preparing... ########################################### [100%] 1:rhn-applet ########################################### [100%] # rpm -Uvh up2date-* Preparing... ###########################...
by lshekter
2006/03/24 00:49:34
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

# rpm -qa 'rh*' 'rpm*' 'python*' 'up2date*' 'yum*' | sort python-2.3.4-14.1 python-devel-2.3.4-14.1 python-elementtree-1.2.6-4 python-sqlite-1.1.6-1 python-tools-2.3.4-14.1 python-urlgrabber-2.9.6-2 rhgb-0.14.1-8 rhn-applet-2.1.22-4.centos4 rhnlib-1.8.1-1.p23.1 rhpl-0.148.3-1 rhythmbox-0.8.8-1 rpm-4...
by lshekter
2006/03/23 01:09:15
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

OK. Let's give it a go: # rpm -Uvh rpm*.rpm Preparing... ########################################### [100%] 1:rpm-libs ########################################### [ 17%] 2:rpm ########################################### [ 33%] 3:rpm-build ########################################### [ 50%] 4:rpmdb-Ce...
by lshekter
2006/03/22 01:53:52
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

Well, I guess I don't understand why it's recommended that I install upgraded versions of these particular rpm's, but I'm the newbie so I'll defer to the experts. But just to confirm what I have, I did this: # rpm -qa rpm* rpmdb-CentOS-4.2-0.20051011 rpm-build-4.3.3-11_nonptl rpm-devel-4.3.3-11_nonp...
by lshekter
2006/03/21 03:48:42
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Re: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

Thank you. I re-installed all the python rpm's you suggested (though version 2.3.4-14.1 rather than -14.2 due to a dependency issue. I had to also install tkinter-2.3.4-14.1, tcl-8.4.7-2 and tix-8.1.4-98). I tried logging out and logging back in but my machine (IBM Thinkpad T42p) froze during the lo...
by lshekter
2006/03/21 00:01:41
Forum: CentOS 4 - Miscellaneous Questions
Topic: Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)
Replies: 20
Views: 7729

Help!! Honey I broke the python! (CentOS 4.2, python 2.3.4)

Hello - First off, I want to say that I really enjoy using CentOS: Thank you! Secondly, I use CentOS 4.2. OK, here's the problem. Basically, I was a bad little CentOS user. I wanted this particular application to work that is dependent upon python 2.4, so, without really thinking about it, I downloa...

Go to advanced search